You have no items in your shopping cart.

Categories

Techland

Dying Light - Vintage Gunslinger Bundle

$ 2.95
Edition:
Dying Light - Vintage Gunslinger Bundle

Other editions

Availability:
Instant download delivery
Add to Cart
Techland

Dying Light - Vintage Gunslinger Bundle

Windows | Steam
Nothing like good old-fashioned law and order. Fight crime as a sheriff armed with the Oathbreaker, the Onyx Thunderbolt, and the Deputy while you patrol your county in the Golden Bull buggy.

Product description

NOTE : Activation key must be used on a valid Steam account, requires internet connection.

NOTE: This content requires Dying Light: The Following expansion pack, the main game Dying Light: The Following and a Steam Account.

 

About the game

Nothing like good old-fashioned law and order. Fight crime as a sheriff armed with the Oathbreaker, the Onyx Thunderbolt, and the Deputy while you patrol your county in the Golden Bull buggy. The Vintage Gunslinger Bundle includes a new character outfit, a new buggy paint job, and blueprints for three new weapons: a shotgun, a revolver, and a long knife.

 

Features:

  • A new character outfit
  • A new buggy paint job
  • Blueprints for three new weapons: a shotgun, a revolver, and a long knife

 

System requirements

Windows Windows:

 

OS: Windows® 7 64-bit / Windows® 8 64-bit / Windows® 8.1 64-bit
Processor: Intel® Core™ i5-2500 @3.3 GHz / AMD FX-8320 @3.5 GHz
Memory: 4 GB RAM DDR3
Hard Drive: 40 GB free space
Graphics: NVIDIA® GeForce® GTX 560 / AMD Radeon™ HD 6870 (1GB VRAM)
DirectX®: Version 11
Sound: DirectX® compatible
Additional Notes: Laptop versions of graphics cards may work but are NOT officially supported. Windows-compatible keyboard, mouse, optional controller (Xbox 360 Controller for Windows recommended)

 

Linux Linux:


OS: Ubuntu 14.04 and newer recommended
Processor: Intel® Core™ i5-2500 @3.3 GHz / AMD FX-8320 @3.5 GHz
Memory: 4 GB RAM DDR3
Hard Drive: 40 GB free space
Graphics: NVIDIA® GeForce® GTX 560 / AMD Radeon™ HD 6870 (1GB VRAM)
Additional Notes: JFS and XFS file systems are not supported

This might also interest you